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About this manual

Documents
supplied

User guide

Complete documentation is provided to help you make optimum
use of the full range of resources offered by your software.

The online help provides instant access to context-sensitive
help.

The Administrator's Guide covers the basic concepts to ensure
you to get the very most from the software. It is designed to
provide effective help for administrators, both first-time and
experienced users.

The User Guide provides an introduction to using the
application. It is designed to get you off to a quick start with the
software by familiarizing you with the basic concepts before
looking at some of the more advanced functions.

The documentation is designed for use in conjunction with the
integrated online help.

The purpose of this guide is to get you off to a quick start with
the software by familiarizing youself with the basic concepts
before looking at some of the more advanced features.
The User Guide contains six sections covering:

* Module description

* Discovering the Mapper module

» Map file definition

» Map file creation
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Typographical
conventions

* The Query Manager
* XML Tutorial

This guide also provides you with workshops allowing you to
walk-through several detailed examples designed to help
you learn and practice mapfile creation.

This manual provides you with the best way to perform
specific tasks. For more detailed information on
functionality, step-by-step procedures and reference
information, please use the online help.

This manual distinguishes between different types of
information using the following conventions:

e Terms taken from the interface itself, such as
commands, appear in bold.

* Keys appear in small caps, for example: "Press the
SHIFT key.”

* Numbered lists mean there is a procedure to follow.

* When the conjunction -or- appears next to a paragraph,
it means there is the choice of another procedure for
carrying out a given task.

When a menu command contains submenus, the menu
name followed by the command to select appear in bold.
Thus, "Go to File > Open” means choose the File menu
then the Open command.
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This symbol highlights important information on

N 2

how a particular command or procedure works.

optimizing tasks, speeding up commands, and so

Following this symbol you will find hints and tips for
; on.



CHAPTER 1

Module Description

This chapter covers the following topics:

* The Application Modules
* Web Manager
* User Manager
* The Kernel
* Sentinel Manager
* Mapper
¢ Query Manager
¢ Plug-ins

Some features may be deactivated or unusable
? depending on the range of the product you're run-
ning
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The application modules can be classified into three
categories depending on their usage in the software.

The first category comprises the kernel module, Sentinel
Manager, the user manager and the Web Manager
application. All of them are used to create, configure and
run sentinels processes. They all come with the
application’s server installation.

The second category comes included with the workstation
installation. 1t comprises of two applications: The Mapper
and the Query Manager. Both are used to preset the
configuration files for the defined sentinels by the server.

The third category is the Plug-in modules. Plug-ins are
thin application modules dedicated to accomplish one
unique task. They perform all the actions a sentinel is
configured to do. They are installed by the both the server
and designer installations.

The application modules

Web Manager

User Manager

Kernel

The Web Manager acts as an interface to the SENTINEL
Server over the Internet/intranet. It allows the user to
interact with any SENTINEL Server, regardless of its
location, via their Internet browser by typing in the web
application’s address in the browser’s address line.

The User Manager secures the internet connections to the
SENTINEL server, by allowing an administrator to set
permissions for application users.

Kernel is the core application that manages all other tasks,
including launching sentinels and monitoring sentinel
activity. If Kernel is closed, all sentinels will be disabled.

Kernel operates as a background task and can be
configured to launch automatically when your workstation is
started. It is therefore not necessary to open a Windows
work session for the application to run.

Once launched from the application program group, the
Kernel module appears as an icon on the Windows taskbar.
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Sentinel
Manager

Mapper

Query Manager

Plug-ins

You can access Sentinel Manager via the Kernel menu.
Step 1 Right-click on the Kernel icon.

Step 2 Choose Sentinel Manager module in the menu.

Sentinel Manager is launched via the Kernel menu and
allows you to create, configure, view status, activate and
deactivate, view the error log and manage the sentinels that
will analyze your datafiles.

Mapper allows you to create and configure the mapfiles
which will analyze your datafiles. A mapfile describes the
structure of the datafiles for analysis and assigns the
mapped data to the corresponding variables in the initial
document. Mapper is accessed via the application program
group or Sentinel Manager.

Mapper features an integrated wizard to guide you through
the process of creating and configuring mapfiles. See the
User Guide for a full description of the module and examples
of how to create mapfiles.

This application module lets you define queries over
different database systems and lets you group them into
tasks that can later be invoked by a sentinel through the use
of the database process plug-in.

Plug-ins are independant modules dedicated to perform a
very specialized task for a sentinel. Plug-ins are controlled
and activated by the kernel module. Four types of plug-ins
are available:

- Input plug-ins

- Process plug-ins
- Report plug-ins
- Output plug-ins
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Discovering the Mapper

This chapter covers the following topics:
* How Mapper Works
* Launching the Mapper

* Description of the main window
* Menu bar
* The toolbar
* The Tree
* The workspace
* The wizard
* The Status bar
* Online help
* Keyboard Shortcuts
* Changing Display Options

* Changing the work environment
» Customizing the control variables
* Defining the test set
» Converting the workfile

This feature may be deactivated or unusable
? depending on the range of the product you're
running.
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How the Mapper works

Before creating sentinels with Sentinel Manager, you must
first define the structure of the datafiles to be analyzed by
the sentinels. This is done using the Mapper.

Mapper features an integrated wizard to guide you through
the process of creating and configuring mapfiles.

Launching the Mapper
You can launch the Mapper by going to:

For Windows versions older than Windows 8: Start >
Programs > TEKLYNX SENTINEL 2019 > Mapper.

For Windows 8 and 8.1 users: Access the search tool. To
access and use the search tool, open the Charms menu by
pressing Win [Windows key] + C on your keyboard or by
swiping in the top-right or bottom-right corner. Once the
Charms menu pops open, click/tap the Search button and
enter Mapper.

For Windows 10 users: Start >All apps > TEKLYNX
SENTINEL 2019 > Mapper or enter Mapper in the Windows
Search bar.

Or by clicking on the Mapper icon in your Sentinel Manager.

=

Figure 1. Mapper icon

Description of the main window

This section presents a general overview of the interface
elements as they appear in the main window at the
beginning of a worksession. The main window is divided into
three areas:

* The tree
* The workspace
* The map creation wizard
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Menu Bar

The Toolbar

The Tree

The menu bar comprises six drop-down menus: File,
Structure, Block, Zone, Options and Help. Select the
function by clicking on the appropriate menu and sub-menu
item. Alternatively, you can use the keyboard shortcuts by
pressing ALT and the key corresponding to the letter
undelined in the menu (or sub-menu) item.

Example:

To access the Save function using the keyboard shortcuts,
you would press ALT+F, followed by ALT+S.

These tools allow you to execute routine tasks more quickly
than using the menus. To select a tool, click on the button
corresponding to the tool.

IRLES RS D e8” @

Figure 2 The Mapper toolbar

i

The tree describes the structure of the file as you define it
and includes additional information such as the target
process used to ease the linkage between the Mapped data
and the variables published by the process plug-ins.
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The Workspace

The Wizard

a Structure
4[5 Targets (1)

CS Label: .\Expe.Lab
. / DB Task:
Inital

document &B Web Method:

filename @ Header: String "{SOHHCRLFY
4 Ol Block Example header
4 =B Zone: D;.:> or start of zone
search methods

< Start: String 'DATE' = 3
> End: String '{CR}’
A, Format value: No
4 @B Zone: ORDER
< Start: String "NUMBER" + 3
> End: String "{CRY'
A, Format value: No
8 Zone: FROM
- Zone: VIA
8 Fone: EXP_TO_NAME
@B Fone: EXP_TO_STREET
& Fone: EXP_TO_CITY
8 Fone: EXP_TO_COUNTRY
8 Fone: TOTAL
W8 Fone: Detail
3 Break: String “{CRLFY - 1
Process: Yes
Al Keep: No
Footer: String "<----'

Figure 3 The Tree

The workspace is used to display the workfile and to define
its structure. This involves selecting the data zones that you
want to retrieve from the datafiles constructed using the
displayed datafile as a model. The color coding enables you
to distinguish clearly between the different types of
elements.

The wizard panel, located in the lower part of the window, is
a step-by-step guide to help you through the process of
creating mapfiles.

The wizard launches automatically when you create a new
map and overrides the application menu commands to
ensure you follow the instructions in the correct order.

The wizard panel is made up of two sections: the left pane
describes the procedure and the actions to be taken,
providing you with detailed information and examples along
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The Status bar

the way; the right pane is the input area. Use the right pane
to enter the different settings necessary to create your
mapfile. Once the map is completed, you can close the
wizard panel by going to Options > Show help panel.
Leaving it open, on the other hand, will give you instant
access to the information you need.

Located along the lower edge of the window, the Status bar
displays the cursor position within the block, the character
code selected with the cursor, and the number of characters
selected.

Cursor position

: ‘ \M2 ‘ 16/166 ‘Selectiam charfs Cilsers\Public\Documents\Tek..\Expedition.
charlxcter Number'of selected Location
code characters
Figure 4 The status bar
Online Help The online help provides reference information and
explanations on procedures. To access the online help, go
to Help > Contents.
Keyboard Keyboard shortcuts are a quicker way to carry out routine
Shortcuts keystrokes. For a full list of keyboard shortcuts, please see
the diagram at the end of this manual.
Changing You can customize your interface by changing the language

Display Options

and modifying the color settings, font attributes and
wordwrap settings used for displaying you workfile by
selecting Options from the menu bar.

You can change the color settings used for each type of
element in the workfile (header, footer, blocks, zones, etc.),
to enable you to distinguish them with greater ease.
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Example:

E Color settings

ltems

Colors

Footer

Block

Zone

Polyzone

Action

#EOFFEQ

Selection

Othes R — 222
G U 255
B U 224

Sample text
| Restore | | OK | | Cancel | Apply

Figure 5 The Color settings dialog box

Step 1 Choose Options > Display Colors.

Step 2 Assign a new color to each element as

required.

A preview of the selected color can be seen in the Sample

text box, just below the color palette.

Step 3 Click OK.

Changing the work environment

Customizing the
control
variables

You can assign a number of different names to each control
variable. You can also define a test set to validate the map.

Control variables allow you to define how a process plug-in
is going to act in regards to the data found in each datafile
block. Control variables of the label printing plug-in let you
define, for example, the label to be printed, the printer on
which to print it, and the quantity to print. The database
plug-in only has one control variable (@TASK) which lets
you specify the task to be executed. Only one control
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Defining the test
set

variable is also given to the web service process plug-in
which can dynamically select the function of the web service
to call through the @WEBMETHOD control variable.

You can use control variable names to assign control
variables to data. In certain cases, particularly when working
with polyzones, you must use an alias.

Step 1 Choose File > Customize control variables.
The Customization dialog box appears.

Step 2 Enter the names to be added to the control vari-
ables in the Other names column.

Step 3 Click OK.

For more information on control variables, refer to the help
topic entitled The Control variable customization dialog box
in the Mapper online help.

Depending on the product version you have installed,
some control variables may not be available.

A test set allows you to run a compliance test on a series of
datafiles to ensure the mapfile structure is correct. The test
results are displayed in a grid.

4 Test set definition *

File zet

o

File named

® Warkfile
C:\Users\Public\Documents\Teklyn:\SENTINEL\Sam..\ZoneOrder. TXT

| 0Ok | | Cancel | | Help |

Figure 6 The Test set definition dialog box
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Converting the
workfile

Step 1 Choose File > Define test set. The Test set
definition dialog box appears.

Step 2 Check the File set option if you want to run
tests on files other than the workfile.

Step 3 Enter the access path to the folder containing
the files on which you want to run the test.

- or —
Click the browse button and select the folder.

Step 4 Enter all or part of the filename in the Files
named box. If you want to run the test on a number of
files or want to refine your search, use an asterisk * to
replace the name, a question mark ? to replace a char-
acter, or simply enter the file extension of the files to be
tested (e.g. *.TXT).

Step 5 Click List to display the list of files to be tested.
Step 6 Click OK.

Step 7 Go to File > Test to run the test and display the
results.

The Mapper allows you to convert tabs into spaces, and
convert the OEM (ASCII) character set into ANSI to make
the workfile easier to read.

You can also use the Decode file option to convert a
datafile coded in UTF-7, UTF-8, Unicode or Reversed
Unicode into a standard Windows text file or the XSF to text
file option to convert an XSF file generated using SAP,
which is difficult to read, into a simple text file
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=3 File conversion ¥

W Tabs to spaces Mumber of spaces

] OEM charset to ANSI 2
[ Decode file

O Replace text

] XML entities to text

T T

Figure 7 The File conversions dialog box

Step 1 Go to File > Convert.

Step 2 Check the required option and insert the correct
number of spaces where applicable.

Step 3 Click Apply to display the result on your work-
space then click OK.
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Discovering Mapfiles

This chapter covers the following topics:

* What is a mapfile
¢ Header
* Block
e Zone
* Footer

» Workfile types
* ASCII Tables
* Form-type structures
* Unformatted/Raw data structures
* Assignment & Table-type Structures
* Direct assignment
* Table assignment



Chapter 3 - 16

User Guide

What is a mapfile ?

Header
(optional)

Blocks

Mapfiles are created using the Mapper. They are used to
define datafile structures so that the information in the
datafile can be interpreted and processed by the sentinels.

Once created, the map is assigned to one or more sentinels
in Sentinel Manager, which uses it as a template for
analyzing similar files generated by your system.

Regardless of the type of datafile to be analyzed, Mapper
provides a straightforward means of organizing the data you
want to retrieve into a hierarchical structure.

Your datafile structure may include a header, footer and any
number of blocks. Blocks may be composed of zones,
which, in turn, may be substructures of the main structure.
The mapfile allows you to define each of these elements
with its respective break and search method.

Structure
Block Substructure
 — |
— o N s Y e |
“} | e [ s Y s— |
) o
{ |
—/
[] Header
E Block
[] Footer
] Zane

Figure 1 Example datafile structure
The header is an information zone located at the beginning
of the structure. It is excluded from datafile analysis simply

by specifying where it ends.

Blocks are structured in the same way as the data they
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Zones

Footer
(optional)

Workfile types

ASCII table

contain. Each block contains a number of data zones used
for label printing.

Blocks are used to describe the repetitive sections of the
datafile, such as table rows or form pages.

Each zone contains a data item to be extracted and has a
corresponding search method defining its start and end.
Mapper will help you locate these zones in each of the
blocks at the same level in the hierarchy.

The file footer is an information zone located at the end of
the structure. It is excluded from data analysis. It is defined
simply by indicating where it starts.

) File footers are searched from the bottom up of
!’ the structure.

The first step in defining the structure involves choosing the
template for organizing the data that will be used. The
definitions and examples of each type of structure listed
below will help you choose the right template.

ASCII table files contain data organized in table format.
Each row in the table represents a record.

The wizard will automatically suggest settings for this type of
file.

The application supports two ASCII table formats:

- Character-delimited. Data items are separated by
commas, semi-colons, or other characters.

- Aligned in columns. The separator is a non-printable
character such as a space or tabulation.
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3654, Aberdeen.
5516, Anderson.
5719,411and,
1913, McFougal.,
2881, Samuelson,
4175, 4A11and,
1989, Aberdeen.
2881, Thampson,
1969,0"'Hare,

Dave,-"1, Discovery Lane", burora,IN,976838F
Warren,-"29558, 42nd Street", Aurora,CO0,9412358F
John,="Pier 43", San Francisco,TH, 376H35E
Emerson,-"1, Discovery Lane", Chicago,IL,S10828E
Doris,-"15, State Street", Birmingham,MI,931055F
Dawve,="5" Wheels, South Flazza", Berkeley,MI,&B5425)
John,-"Time Square", Aurora,C0,947045E
Dave,-17 Norfolk Way, Birmingham,Ch, 518828k
Craig,-2935 42nd Street, New York,OR.,94123§E

Figure 2 Example of a character-delimited ASCII table

n HuL on A vec nag D1ZEe |\min) yp U1STance LOmnon Hame

1 1952 Tau 05°34.5 22°01 9.0 6= 4 SHE 6.3 Crab Hebula

2 7089 Agr 21°33.5 -00°49 7.5 12.9 GCl 36

3 5272 CW¥Wn 13°42.2 28723 7.0 1s.2 GCl 31

4 6121 Sco 16723.6 —267°32 7.5 26.3 GCl 7

5 5904 Ser 15°18.6 02°0% 7.0 17.4 GCl 23

6 6405 Sco 17740.1 -32°13 4.5 1s5.0 ocl 2 Butterfly Cluster

7 6475 Sco 17°53.9 -34°49 3.5 &80.0 ocl 1 Ptolemy's Cluster

8 6523 Sgr 18°03.8 -24°23 5.0 &0 = 35 C-H 6.5 Lagoon Hebula

9 6333 Oph 17°19.2 -18°31 9.0 9.3 GC1 26

10 6254 Oph 16°57.1 -04706 7.5 15.1 GCl 13

11 6705 Sct 18°51.1 -06°16 7.0 14.0 ocl [} Uild Duck Cluster

12 6218 Oph 167°47.2 -01°57 g.0 14.5 GCl 18

13 6205 Her 167°41.7 36728 7.0 1s.6 GCl 22 Hercules Cluster

14 6402 Oph 17°37.6 -0371% 9.5 11.7 GCl 27

15 7078 Peg 21°30.0 12710 7.5 12.3 GCl 38

Figure 3 Example of an ASCII table aligned in columns

Form-type Form-type structures are composed of data organized into
structure multiple rows. In other words, each record contains a

number of rows.

With this type of file, you must select the different data zones
you want to retrieve from the datafile one by one.
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DATE : DEC 22 L9998L
ORDER MUMBER : 45-TYX/5628F

ITEM REF FIECES WEIGHT MNET(Kg) SHIFFING COSTE
ME Sockets AKF4-EC ¥IA KT133 HI-11442-CDE& 1158 375 g EETE S539.88 &8
ME Socket423 6339 858 Pro P4 LP-78512-ER2 854 285 g 24z 30280 &5
ME Socket37@ CAG3 EM YIA ATAled KL-78542-052 4228 295 g 1244 1556.10 &
CFU Socket378 888 Mhz MC-78541-CxX1 288 58 g 14 17.58 $&
CPU Sochket37?@ 1 Ghz MR-45621 sa 58 g 2 3.18 $&
CPU Socket37a 733 Mhz LU-78455-RE4 148 S8 ¢ 7 &.78 &8
INSURANCE 234 .98 $&
SHIFPING TOTaL 5383.85 $&
FROM : Colorado Springs Depotgk
FREIGHTER : US POSTAL SERYICESE
Too: Iroshi Groupgk

- Figure 4 Example of a form-type file
Unformatted/ Unformatted files contain characters that are not organized
raw data into any type of page setup. They are difficult to read and are
structure generally used for automated data processing only.

With this type of file, you must select the different data zones
you want to retrieve from the datafile one by one.

“EATHCY X2

XA LRN FWN"CFD,24"LHB,8"CIA"PRATLLG39 " PON"PHN
“¥2°XA"A6N,36,36°F010,220°CIA"FDSSCC :°FS
“H8M,36,36 FOL4YS 288 CI0"FDEAN Ma:"FS

“fnBM,36,36 F08,171"CIA FDCDR 650/74H : A562H3"FS
“ABM,36,36°F0120,228 CI0"FD331245645645646578 FS
“ABN,41,38°F0581,276 " CIA FDB31234567890127F5
“BY3"F0239,339"BCN,112,V,N,N"FD> ; 0183123456789 812 FS
“BY3"F0286,492"°BCH,112,¥ ,N,N"FD> ; BA331245 645645446578 FS
“PQ1,8,1,¥

"Xz

Figure 5 Example of an unformatted/raw data file

Assignmentand  Assignment and table-type files contain data organized by

table-type direct assignment and/or table assignment. With this type of

structure file, only the syntax of the assignments appearing in the file
needs to be defined in the Mapper.
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* Direct assignment
syntax

* Table assignment
syntax

Each line describing a variable for analysis must begin with
a start of assignment delimiter, followed by the variable
name, the assignment operator, then the variable value. It
must end with an end of assignment delimiter.

Var1(3) Value

Assignment Operator

A table assignment datafile groups variables into a table
containing two elements:

* A header specifying the variable associated with
each column in the table. The header must be enclosed
by a start of table header delimiter and an end of table
header delimiter.

¢ A set of values associated with the header variables,
enclosed by a start of table delimiter and an end of table
delimiter.

Data processing will take place for each row of the table.

The variables listed will either be control variables of a
process plug-in or variables involved for data processing.

The advantage to this type of structure is that it can provide
dynamic analysis for a sentinel. For example, with such a
configuration, the same sentinel is able to analyze files that
can be have differences between them as they could define
labels with a different number of variables and with different
names.

Mapper features map and zone creation wizards to guide
you through the entire structure definition process.

The map creation wizard launches automatically when you
select File > New to create a new map. It will take you step-
by-step through the process of creating your mapfile,
displaying instructions and hints to help you during each
step.
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XML

The zone creation wizard will guide you through the process
of creating zones and automatically suggests the best
method for locating the zones containing the data to be
extracted.

XML is a specification of the World Wide Web Consortium
for creating web documents. It provides a flexible way to
exchange information between applications and systems as
it allows the simultaneous transfer of data and information
structure. It is now widespread in very different situations
from Electronic Data Interchange (EDI) to web service
method calls over the internet/intranet.

XML documents are text documents but they are displayed
in the Mapper as a hierarchical structure organized into
nodes and sub-nodes with attributes. Blocks of data must
be defined by simply indicating the node on which
processing should occur. Zones to be set up for the block
must then be defined one by one.



CHAPTER 4

Creating a Mapfile

This chapter covers the following topics:

* Creating a mapfile: Basic Techniques
* The initial document
* Creating a mapfile
* Modifying a block
* Creating zones
* Creating a simple or structured zone
* Duplicating a zone
* Renaming a zone
* Renaming a structure
* Creating a polyzone
* Creating an action
* Search methods
* Printing the settings
* Modifying the settings
* Creating and modifying an target document

* Creating a mapfile: Advanced Techniques
* Factors specific to assignment and table files
* Defining the settings
* Creating a substructure
« Creating a zone containing a substructure
» Zone sorting
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Creating a mapfile — Basic Techniques

Creating a mapfile is easy if you follow the mapping wizard’s
instructions! First, you must locate the datafile you will be
using (this will be called your workfile). Then, you must
define your file’s structure type and categorize the file into
blocks and zones. To finish, you must link the zone in your
workfile to the variables published by the process plug-ins.

For examples on how to create maps, please see
Q Appendix B, at the end of this manual.

Target Target Process configuration helps you link mapped data
Processes with the variables retrieved by the process plug-ins available
with your product.

nels are running as configuration

priority is first given to coded variables in the file
(@TASK or @PRINTER) then to the plug-in
setting in the Sentinel Manager, and lastly, to the
setting in the Mapper’s target processes.

Q This information does not apply once the senti-

Label: The label that will be used to print the mapfile’s data.
To select a label, double-click on a label entry and browse
for the appropriate .lab file. If you own a designer version of
this software, you can also create a new label or modify an
existing label by launching your labeling software from
Mapper: Click on label entry (to make it bold), go to
Structure > Create (or) Modify initial document.

feature may not be available. Launch the designer
apart from the Mapper to create your label if this is
the case.

Q Depending on your version of the product, this

DB task: The task which will be performed by the sentinel
on the workfile. To select, double-click on the db task entry
and select the check box corresponding to the chosen task.
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Creating a
mapfile

(Tasks are created, modified or deleted using the Query
Manager. See Chapter 5 for more information).

Web Method: The web service function which will call the
mapfile’s data. To select, double-click on the Web Method
entry and choose the desired function. If the listbox is empty
click Add to browse for a web service and select the method
to be used by the Web Service plug-in (see the
Administrator’s Guide for more details about configuring the
Web Service plug-in) .

@

The

To preview the data with the label, task or web
method applied to it, ensure that the initial
document of choice has been selected (it will
appear bolded) and go to Structure > Preview
or click on the Preview icon.

Step 1 Launch Mapper from:

For Windows versions older than Windows 8:Start >
Programs > TEKLYNX SENTINEL 2019 > Mapper.
For Windows 8 and 8.1 users: Access the search tool.
To access and use the search tool, open the Charms
menu by pressing Win [Windows key] + C on your key-
board or by swiping in the top-right or bottom-right cor-
ner. Once the Charms menu pops open, click/tap the
Search button and enter Mapper..

For Windows 10 users: Start >All apps > TEKLYNX
SENTINEL 2019 > Mapper or enter Mapper in the
Windows Search bar.

Step 2 Go to File > New or click on \j to create a
new mapfile.
creation wizard launches automatically.

While using the creation wizard, most of the menu

commands will be disabled. Only those linked to
interface options will remain active.
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* Modifying a block

Step 3 Enter the name and access path of the workfile
you will be using or click on the browse button to
search for it.

Step 4 Select a conversion or formatting type
according to your workfile:

* File conversions

* Wordwrap

* Display font

Step 5 Click on

Step 6 Enter a mapfile name and its location. By
default, the file is saved in the application Maps folder.

to configure the settings.

Step 7 Select a Structure type.

Step 8 Your next steps will depend on the structure
type you have selected.

Step 9 If necessary, define a header and footer and

configure the appropriate settings by clicking on

When defining your block, the Process option is
checked by default as it is the block break which
launches data processing. The Keep Data allows
you to specify whether the variable values will be
in the next block the next label if the

corresponding zones are missing.

Step 10 Select the initial document.

Step 11 Click on Done and Finish.

Defining a block simply involves specifying where it ends. In
principle, the first block begins immediately after the file
header and ends at the break you set. If the workfile
contains more than one block, this break marks the
beginning of the next block. If the workfile contains only one
block, it marks the end of the file.
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Step 1 Select the block in the tree then right-click to
display the context menu.

Step 2 Click Define.

The Block definition dialog box appears and
suggests various search methods.

Step 3 Select the most appropriate search method for
locating the break.

Step 4 Once the search method is selected, enter the
data that characterizes the break then click OK.

structure including the file header, footer and

You can modify virtually all elements in the
; zones.

You have now defined the main structure for your workfile.
The tree displays the different elements that make up the
structure and their associated search methods. You must
now define the zones containing the data to be extracted.

* Creating Zones There are three types of zones:
* zone
* polyzone
* action
A zone defines the position of the data to be extracted.
| Date
ORDERNUMBER({45T126 )-——Order

Number
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Creating a simple or structured zone

The

?

The
end

Step 1 Select the data in the workfile using the cursor.

ORDER NUMBER : 4CT86208

Step 2 Go to Zone > New zone.

- or -

Right-click and choose New zone in the context menu.
- Or -

Click on g

The zone creation wizard appears in the lower part of
the window.

Step 3 Enter a name for the zone or select the name of
the variable in the initial document to which it will be
assigned.

Step 4 The wizard will suggest a search method for
the zone which you can modify if it does not
correspond to the zone you want to create.

next steps allow you to format the data.

Step 5 Under Zone content, select Simple data or
Structured data.

Step 6 Click on Finish.

Simple Data refers to a single piece of data. Ex: a
date, a name, etc. Structured Data refers to an
area that can be sub-divided into simple data
zones.

new zone appears in the tree with its name, start and
of zone search methods, and formatting. The

corresponding data is underlined in the workfile.
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Duplicating a zone
Step 1 Select the zone in the tree.

Step 2 Choose Duplicate in the context menu.
The new zone appears in the tree followed by “copy no. x”.

When the name of the zone you want to duplicate ends with
a number, the new zone will end with the same number plus
one. For example, Address1 becomes Address2, Row017
becomes Row018, and so on.

When the zone you want to duplicate uses the String
occurrences search method, the new zone will use the
same search method with the number of occurrences plus

one. For example, 3 x {CRLF} becomes 4 x {CRLF}, and so
on.

_ When you duplicate a zone containing a
! substructure, the entire substructure is also
duplicated.

Renaming a zone
Step 1 Select the zone in the tree.

Step 2 Choose Rename in the context menu.

Step 3 Enter a new name in the box.

Renaming a structure
Step 1 Go to Structure > Rename
- or-
Choose Rename in the context menu.

Step 2 Enter a new name in the box.
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Creating a Polyzone

A polyzone is a zone that may appear a number of times
within the same data block. While a zone is associated with
a variable defined once, in a datafile, during map creation, a
polyzone contains information specifying the name of the
variable and the corresponding data which are not specified
until file analysis begins.

A polyzone is defined by the following elements:
« A start of assignment delimiter

» An assignment operator
* An end of assignment delimiter.

LET FIRSTNAME = “Dave”

LET NAME = “Aberdeen”

LET ADDRESS = “1 Palace Street”
LET CITY = “Portland”

Label Variable Data

An action is a zone that launches a process such as
selecting a new document or printer or assigning a value to
the variable selected.

CALL RESET()
CALL FEED()

Step 1 Select the data in the workfile using the cursor.
Step 2 Go to Zone > New polyzone.

_Or_
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Right-click and choose New polyzone in the
context menu.

- Or_
Click on &

The zone creation wizard appears in the lower part of
the window.

Step 3 Enter a name for the polyzone.

Step 4 The wizard will suggest a search method and
assignment symbol for the zone.

Step 5 Apply any necessary formatting.
The new polyzone appears in the tree with its name, start
and end of zone search methods, assignment symbol, and
formatting. All sections of the block corresponding to these
criteria are underlined.
Creating an action
Step 1 Select the data in the workfile using the cursor.
Step 2 Go to Zone > New action.

_Or_

Right-click and choose New action in the con-
text menu.

- Or -
Click on
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e Search Methods

3 Action definition b

Set a document variable Variable
Set a control variable
Mo process WSl

Stop analysis
[ Prioritize

[ ok |[ ancel || apply

Figure 1 The Action definition dialog box

Step 3 Select an action from the list.
Step 4 Complete the action settings.

Step 5 If necessary, check the Prioritize* option then
click on OK.

The new action appears in the tree with its name, start of
zone, type of action, and settings.

Prioritize option specifies which one will be

If the same result is obtained by another zone, the
; applied.

Using a non-prioritized action to assign an existing value
may produce a default value if the zone is not found.

Search methods are used to delimit the start and end of a
file, block, or zone.

The table below lists the different search methods and their
functions.
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* Printing the
settings

* Modifying the
settings

Creating and
modifying a
target
document

Search method How to use

No search To disable the search for a given element.

Fixed position The element starts or finishes after n
characters.

Character string The element is located after a fixed text
string.

String occurrences The element is located after the nth
occurrence of a fixed text string.

Character from set The element starts or finishes with the first
occurrence of one of the characters from the
set.

Character not from set | The element starts or finishes with the first
occurrence of a character not from the set.

The zone follows The element is located immediately after
immediately after another zone.
another one.

Cascading strings The element is located immediately after a
fixed text string, which is itself located
immediately after another fixed text string.

You can print the settings made. The printout will list all
settings in the structure you have just defined.

Go to File > Print the map settings.

You can modify elements in the structure you have defined
directly from the tree.

You can launch your labeling software directly from Mapper
to create or update your initial document. Mapper then
initializes the list of variables, their lengths and current
values. All that remains is to place these variables in your
label as text, barcodes or graphics. For more information on
creating labels, refer to the documentation that came with
your labeling software.

Remember to save the initial document in your labeling
software before returning to Mapper.

The Create a document command is only available if no
initial document (.lab) was selected during the map creation
process.
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The Create a document and Update the

N 2

document commands in the Structure menu are
only visible if a Designer version of your labeling
software is installed on your workstation.

document:

To preview the label to be printed ex: the initial
; Go to Structure > Preview

-0or—

click on @
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Creating a mapfile: Advanced Techniques

Factors specific

to assignment
and table files

* Defining the
settings

Creating a
substructure

¢ Creating a zone
containing a
substructure

Zone sorting

Creating a map using an assignment and table file involves
defining a number of specific ASCII sentinel settings from
the previous version of the application.

Step 1 Create the structure using the wizard.

A message will appear, informing you that you must
define settings in a separate dialog box.

Step 2 Go to Structure > Specific properties.

The Assignment & table properties dialog box
appears.

Step 3 Complete the boxes according to the
characteristics of your datafiles.

A substructure is simply a structure contained within the
main structure and includes data organized in table form or
as a list. This data, while included in the same datafile, is
used for printing another document. Substructures are
treated in exactly the same way as main structures. They
are used chiefly in form-type files.

Step 1 Select the part of the zone that will make up the
substructure.

Step 2 Repeat the above procedure for creating a
zone until the selection of zone content step.

Step 3 Check Substructure as zone content.

This will take you back to the map creation process. You
must now define the header, footer, initial document, and so
on, of the substructure.

The new substructure appears in the tree and has the
default name Structure. To return to the main structure,
choose Structure Up one level or click on

Zone sorting is particularly important for files containing
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substructures as the different elements are searched for
and/or processed in the order they appear in the tree:

* Analysis of the first zone in the main structure,
including its substructures

« Full analysis and substructure(s) data processing
* Analysis of next zone(s) in the main structure

* Processing of the main structure.

substructure it contains, the main zone must
appear before the substructures in the tree. If, on
the other hand, you want to use zones to define
printing settings (printer name, document name,
etc.), you must place them after the substructure
so that it will not modify their content.

Q If you need to reuse values from a main zone in a

Step 1 Go to Block > Zone sorting.

Step 2 Select the zone to be moved.

Step 3 Use the T .L buttons to move it up and
down in the list.

Step 4 Repeat the above operation until all zones are
in the correct order.

Step 5 Click OK.

You can also use the CTRL 4 (up arrow) and CTRL v
(down arrow) keyboard shortcuts to move zones within the
tree.
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Query Manager

This chapter covers the following topics:
* Using the Query Manager

* About the tables
* Creating new table
 Searching for a record
* Applying the filter

* About the queries
« Creating a new query

* About the tasks
 Creating a new task

¢ About the Stored Procedures

* Setting an alias
* Defining an alias

* Setting a fixed value
* Defining a fixed value

This feature may be deactivated or unusable
? depending on the range of the product you're
running.
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The Query Manager is an add-on feature of the SENTINEL
Server that lets you define queries and tasks, create new
tables, and view stored procedures over your database
system. These can be grouped together into tasks that can
be executed via the Database process plug-in.

You require an additional license for the Database plug-
in in order to use it in conjunction with this module.
Please contact your reseller to activate this
functionality and ensure your database system is
supported.

Using the Query Manager

The possibilities on what can be achieved with the Query
Manager are endless. The following steps will take you
through one example of what can be done:

Step 1 Launch Query Manager by going to:

For Windows versions older than Windows 8:Start >
Programs > TEKLYNX SENTINEL 2019 > Query
Manager.

For Windows 8 and 8.1 users: Access the search tool.
To access and use the search tool, open the Charms
menu by pressing Win [Windows key] + C on your key-
board or by swiping in the top-right or bottom-right cor-
ner. Once the Charms menu pops open, click/tap the
Search button and enter Query Manager.

For Windows 10 users: Start >All apps > TEKLYNX
SENTINEL 2019 > Query Manager or enter Query
Manager in the Windows Search bar.

You can also launch it by clicking on the Query Man-

ager icon i

. from Sentinel Manager

Step 2 Define a Datasource. Go to File > New
Data source. A list of possible database system pro-
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viders is shown. Select the one that best corresponds
to your database.

Step 3 Depending on the provider chosen, at this
step, you will be selecting a Server Name from the
drop-down menu and/or a Database Name. Click
Refresh.

Step 4 Test the connection and click OK

Depending on the provider selected, a different
configuration may be required from that which is listed
above.

Step 5 Enter a name for the new datasource.

Expanding the datasource will show any Tables, Queries
and Stored Procedures belonging to the database. New
tables and queries can be created using the Query
Manager; however, Stored Procedures cannot.

Once a datasource has been created, tables and queries
must be defined in order to retrieve information and populate
the defined table and database.

About the tables

Once you have defined a datasource from the list available
and a database, any tables already present in the database
will be displayed. If they are not, expand the list of tables by
double-clicking on Tables or on the x to the left of the list.

Double-clicking on a chosen table will display its contents in
the right-hand window. Click on 8 to view the structure

of the table detailing each field, the type of parameter, the
paramenter length.

The structure can be changed by the user. Click on‘ " lto
view the data in the table.
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Select Search Field Deselect All

Case Sensitive
Cancel Filter

|
- mgﬁryvk

Enter Field Value Select All
Apply filter

The toolbar displayed above the table data can be used to
search a specific record in a table or to define a filter so that
only information matching the filter is displayed.

Creating a new Step 1 Create a table by right-clicking on Tables and
table selecting New...

Step 2 Click on @ to show the table structure.

Step 3 Enter all the fields you would like to add, their
character type, length, and other details. Scale refers
to the number of placeholders following a decimal
(entering 2 = 1.00).

Example:

Table: test_table example

Name Type Length Scale Allow Unique
Nul
Nom VarChar 200 Yes No
Prénom VarChar 200 Yes No
Adresse | VarChar 200 Yes No
Ville VarChar 200 Yes No

You can populate your fields manually by clicking on
and entering the data corresponding to e