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About this manual

Typographical This manual distinguishes between different types of
conventions information using the following conventions:

» Terms taken from the interface itself, such as commands,
appear in bold.

* Keys appear in small caps, for example: Press the sHiFT
key.

* Numbered lists indicate that there is a procedure to follow.

* When the conjunction -or- appears next to a paragraph, it
means there is the option of a different procedure for
carrying out a given task.

« When a menu command contains submenus, the menu
name, followed by the command to select, appears in bold.
Thus, “Go to File > Open” means go to the File menu, then
the Open command.

This symbol highlights important information on

.i how a particular command or procedure works.
L

for optimizing tasks, speeding up commands, and

Following this symbol, you will find hints and tips
; other helpful information.
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Introduction

Welcome!

TEKLYNX label design and integration software provides an
easy-to-use, user-friendly solution for printing bar code labels
and tags to meet compliance standards in any industry.

What is this guide?

This guide provides information to help you understand how to
manage your labeling software in the context of an enterprise
environment.

Who should read this guide?

This Administrator’s Guide is for IT personnel (system and
network administrators) who are responsible for managing the
deployment of software applications, specifically on the
Microsoft Windows platform.
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Product description

Your product includes the following components:

A DVD for the installation
Complete documentation
A license agreement

A protection key, either electronic (software key) or
hard key (dongle)

System requirements

The configuration required for the software to run properly is
the same as most applications running on Windows:

OPERATING SYSTEM
Windows® 7 SP1 x86/x64
Windows® 8 x86/x64

Windows® 8.1 x86/x64
Windows® 10 x86/x64
Windows® Server 2008 R2 SP1
Windows® Server 2012, 2012 R2
Windows® Server 2016
Windows® Server 2019

VIRTUAL MACHINE PLATFORMS
Requires VM license

MEMORY
2GB or more RAM (4GB recommended - depending on
OS and usage)

HARD DISK SPACE
A hard drive with at least 1.5 GB free disk space
(depending on the installation options).

DISPLAY

Windows display adapter capable of 1024x768 with
True Color capabilities and DirectX® 9 (DirectX 11
compliant card recommended).

SUPPORTING SOFTWARE

Microsoft .NET Framework 4.6.1 (provided with the
installation)

Any pdf reader (Adobe Acrobat Reader is available
with the installation)
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+ ADDITIONAL REQUIREMENTS

Installation requires full Administrator privileges.

At least one printer driver installed on computer.

The following is required for Online licenses:
- Internet access to license server
- Ports 80 and 443 must be open (proxy, firewall)
- Proxy authentication is not directly supported for

Online licenses

The ReleaseUS.html file contains the Ilatest
information on the software. This information

supersedes the information contained in this
manual.
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Installing the Software

Functional description

The network (multi-user) packages allow you to control access
to the labeling software licenses over the network. Using this
utility, you can have multiple users accessing the label design
software at the same time, from anywhere on the network.

To use the network/multi-user version of your labeling software,
you must install the Network License Manager on the server
or on a station that will serve as a server, then install the labeling

software on each workstation.
Installation of the Network License Manager

— [0

— ““Workstation

Figure 1: Network Configuration Installation.
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Installation procedure

Before you start

Network
Manager

Installing the
Network License
Manager

Before you can install the software, the network
administrator must first define the structure of the network
for the group of users, specifically:

+ Define the license server on which the Network
License Manager and the dongle will be installed.

+ Define the client workstations that will use the labeling
software.

The Network License Manager let you define the network
configuration of your labeling software. It includes:

» The Network License Manager (License Service)

Network Settings Wizard, which helps you define the
network configuration.

Before installing the labeling software on all the workstations
that will use it, you must first install the License Service utility
on the server to configure the network.

To install the Network License Manager on the server:

1 Insert the DVD in the appropriate drive.

The Installation window is displayed.

If the DVD does not run automatically, go to Windows
explorer and expand the letter of the DVD drive. Double click

index.hta.

2 Select Network License Manager, which includes
License Service. Then, click the Install button.

3 Follow the instructions on the screen.

4 If you want to define settings for your network
configuration, start the Network Settings Wizard on the
server. If you do not modify the configuration, each
workstation will have its own settings.
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Configuration

Share the TKpongle folder with full control, using
TKbongle as the share name. The default access path
for this folder is
C:\ProgramData\TKI\LicenseManager\ TKDongle

RIGHT CLICK > Properties > Sharing tab and Per-
missions button.

For administrators:
Users wanting Write Access to the Network
license must be given the rights by:

1. Sharing the TKDongle folder and authorizing
the user:
C:\ProgramData\TKI\LicenseManager\
TKDongle)

Right-click > Properties > Sharing tab and Per-
missions button.

2. Give Write Access to the user on the Security
tab of the TKDongle properties.

All the necessary tools to configure the network version are
available from the Network toolbar, which can be accessed
from the Windows taskbar (Systray).

From the Window taskbar, double-click on the icon ;; to
have the Network toolbar displayed.

The Network Settings Wizard helps you define the settings
for your network version.

1 Start the Network Settings Wizard.
2 Select a settings mode: Generic, By user or By station.

* Generic: All users will use the same settings on
all workstations. (user.ini).

* By user: Each user can access his or her own settings
on any workstation. (user name.ini).

+ By station: Each workstation has its own settings
(station.ini).
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Starting the
License Service

Installing the
software on the
workstations

3 Specify the location in which you want to store these
settings. If you want to share these settings between
various workstations, specify a network path accessible
to all workstations. (for example TKDongle).

4 Specify the location in which you want to store the shared
data (variables, lists, printing lodfile, etc.). Be sure all
users have appropriate access on these folders.

Before installing the labeling software on all workstations,
you must be sure the License Service is started.

The License Service was installed as a service called
SLicense. You do not need to manually start it. In fact,
SLicense starts when the workstation is turned on and runs
as a background task as long as the workstation is on.

_ If you installed the Service License as software key
"' protected, you must activate the license before it will

- tart automatically.

To start the Service Controller

* Click the @ icon on the Network toolbar
-or-

» Double-click the sLicensecTrLEXE file.

The labeling software must be installed on all the
workstations on which it will be used.

To install the software on a workstation

1 Insert the DVD for the installation in the appropriate drive.

The Installation window is displayed.
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If the DVD does not run automatically, Go to Windows
explorer and expand the letter of the DVD drive. Double click
on index.hta.

2 Select the product to be installed, click the Install button,

and follow the instructions on the screen.

Start the labeling software. The License Manager is
displayed. Click Try to launch the software. From the
Tools menu, choose Network Administration.

_or_

From Windows Start menu, select Network
Administration shortcut in the labeling software group.

Enable Use Network License.

Click Modify to select the server on which the Network
License Manager is installed.

-0r -

Click Browse to automatically search for the server on
which the Network License Manager is installed.

If the network settings have already been configured, a
message asking if you want to use the current network
configuration is displayed.

If you want to modify or configure the network settings,
click the Network Settings Wizard button ﬁ.

Click OK.

Restart the program.

If the server is changed, you will have to update all
of the workstations. In this case, start the labeling
software and choose Tools > Network Adminis-
tration. Disable and re-enable the Use Network
License option.
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License protection

Hardware Key
protection

Your software can be protected using a software key (an
electronic code) or a hardware key (a dongle).

* The dongle is a small electronic device that you plug
into your PC’s parallel or USB port before launching the
software.

» The software key is an electronic code that is requested
by the License Manager when you launch the
software for the first time or as long as you have not
activated the software.

You must first install the software and then activate or
connect the protection key to your computer.

The protection key must be installed on the computer on
which the License Service is installed. A single protection
key, pre-programmed with the number of licenses
purchased, is included with the network version of your
software.

The dongle must be installed before the License Service
can be started.

If you have purchased a software with a dongle, you can
choose between a USB or parallel port dongle.

Connecting the parallel key

Parallel port'DB25 female connection
PC foimyn I—l
=
k'-Kn;-.g.'

Figure 2: Connecting the dongle to the parallel port on your PC
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Error messages
when launching
the software

port, simply plug it into the software protection key.
In this case, it might be necessary to turn the
printer on in order for the software protection key
to be recognized.

Q If you need to use a printer on the same parallel

Connecting the USB key

/9 UsB Port?® |
G&— |

Key

Figure 3: Connecting the dongle to the USB port of your PC

When you use a USB key and have multiple USB ports, it
does not matter which port you use. If you do not have an
available USB port, you can use a USB expander hub. USB
devices are hot-swappable, meaning you can plug and
unplug them at any time without restarting the PC.

Drivers can be installed while the application is
running. However, you must restart your labeling
software for the changes to take effect.

If you receive an error message when launching the
software, please check the following items:

+ Administrative rights. You must have local
administrative rights on your PC for the key installation
to work properly. If you do not have these access
rights, you will see an error message when launching
the software, and you will have to manually install the
drivers.

+ Driver installation. If you had trouble during installation
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Installing the
driver key
manually

Software key
protection

or if you receive an error message when launching the
software, you will have to manually install the drivers.

» The key. If you receive an error message when
launching the software, check that the connected key
works with your software.

+ Driver update. If you receive an error message when
launching the software, your driver may not be
updated. To update your driver, download the new
version from:

https://sentinelcustomer.gemalto.com/sentineldownloads/
?s=&c=End+User&p=Sentinel+HASP&o=Windows&t=Runt
ime+%26+Device+Driver&l=all

To manually install the key driver:
1 Go to Windows explorer.

2 Enter [Product Install Folder\Tools\Dongle\ then type the
following command: \HaspDinst.exe -i

It is recommended that you close your labeling
software and other applications before installing
your driver.

Once you have installed the labeling software, the License
Manager will be launched, taking you step-by-step through
the software key protection process.

To activate the software key
In the License Manager, select Activate.
There are four possible activation methods: Online

activation, Using a USB key, Using a smartphone and
Using our website.

If you have an Internet connection on the computer
where the software is installed, online activation is


https://sentinelcustomer.gemalto.com/sentineldownloads/?s=&c=End+User&p=Sentinel+HASP&o=Windows&t=Runtime+%26+Device+Driver&l=all
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automatically selected.

Online activation

Some enterprise networks are protected by a proxy server.
In this case, there is an extra step which allows you to enter
the IP address and connect to the Internet.

1 Enter the Serial number and the password provided
with the product and click Next.

2 Enter or edit your information in the User Registration
form. Click Next.

3 Click Finish.

The following is required for Online licenses:

- Internet access to license server

- Ports 80 and 443 must be open (proxy, firewall)

- Proxy authentication is not directly supported for
Online licenses

If you do not have an Internet connection on the
computer where the software is installed but you
have access to another computer with an Internet
connection, you can activate the product using a
USB key.

Using a USB ke

1 Enter the Serial number and the password provided with
the product and click Next.

2 Select Using a USB key.
3 Select the media to be used for activation (USB key or

external hard disk or network drives) and click Next. Files
for activation will be copied onto the selected media.
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4 USB devices only: Unplug the removable media and plug
it into the computer connected to Internet.

5 On the computer connected to the Internet, double-click
USBWizard.exe (which can be found on the root of the
media). This will start the License Manager.

6 Select the license(s) to activate and click Next.

7 Enter or edit your information in the User Registration
form. Click Next.

A message will inform you that the activation information
for the selected license(s) has been successfully
retrieved.

8 USB devices only: Unplug the removable media from
this computer and plug it back into the computer where
the software is installed.

9 On the computer where the software is installed, double-
click USBWizard.exe again (the file can be found on the
root of the media).

The wizard will display the license that can be activated
on the computer where the software is installed.

10 Click Next.
11 Click Finish.
If any problems were encountered, a message will inform

you that the activation has failed and an error will be
displayed.

If you do not have access to a computer with an
Internet connection, you can activate the product
using a smartphone.

Using a smartphone

A barcode scanner application is required to read the
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barcode which allows you to activate your software using a
smartphone. You can download this from your application
store / market. This activation mode uses an Internet
connection on your smartphone.

1 Enter the Serial number and Password provided with
the software and click Next.

2 Select Using a smartphone.

3 Input your information in the User Registration form. Click
on Next.

4 A barcode appears. Move the cursor over the barcode to
zoom in.

5 Open your barcode scanner application on
your smartphone.

6 Scan the barcode with your smartphone.

7 Click Continue or open the browser on the phone.

8 The Software Activation website is displayed. This allows
you to register and activate your software. All fields must
be filled in.

9 Click Submit.

The Validation code and Installation code are
displayed at the bottom of the Software Activation

website page. Please scroll down if necessary.

10 Enter the Validation code and Installation code in the
wizard (using uppercase characters).

11 Click Next.

12 Click Finish.

Using our website

1 Enter the Serial number and Password provided with
the software and click Next.
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Select Using our website.

The link provided on this screen (https:/
www.teklynx.com/nsp/) can be reached from a different
computer with Internet access. You or someone else with
an Internet connection can connect to our website to
complete the activation. The Serial Number and
Password (provided with the product) and the User
Code (displayed in the wizard) will be required in order to
use this service.

Enter the license user's information in the User
Registration form displayed on our website. Click Next.

Click Submit.
The Validation code and Installation code are
displayed on our website. Enter these in the wizard

(using uppercase characters) and click Next.

Click Finish.
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Managing users

License
Service
Controller

The License Service is installed as a service. This service,
referred to as SLicense, is enabled automatically when the
server is turned on.

The License Service Controller module, named
SLicenseCtrl.exe, is used to control how the service functions
and to change the standard behavior of the License Service.
You can, for example:

+ Start or stop the service

+ Display the list of users connected to the labeling software

Description of the License Service Controller window
To start License Service Controller
* Click the @ icon on the Network toolbar
-or-

» Double-click the sLicensecTRLEXE file.
_or_

* Right-click on the Network bar icon from the Windows
taskbar and select Service Controller.

Once started and the window is enabled, the License Service
Controller window is displayed as follows:
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Toolbar

Indicator panel

Frame reserved for
status or error

messages.
Uszers
. Uszers 1
List of users T
connected to the Uszers 3
labelling software. Users 4
9 Usgers 5

3 License Service M= =
.l 0 3 2|
— B3

Licenze Service iz stopped. Click an the
"Start'' [»] button,

—

Figure 4: Main Service Control window

The License Service Controller window displays the list of
users. This list permanently displays the login name of those
currently using the labeling software.

The License Server Controller window toolbar contains the
following buttons:

Stops the service.
Starts the service.

Refreshes the display: The list of users may not
be updated in certain cases, such as if a
workstation crashes. To reset a workstation,
press CTRL+ALT+DEL.

Accesses the Service Control Settings window.
This button is only available when the service is
stopped.

Displays the About window. This window
displays the version number of the program.
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The Indicator Panel

The Indicator panel displays the current status of the

service.
Indicator = Red: The Indicator. = Orange: Indicator = Green: The
service is stopped. The service is starting  gervice is enabled.

up.

The Settings dialog box

To access the Settings window, click &l

The Settings window is displayed.

Settings §|
License file path
CADocuments and Settings\all Users\dpplication DatalTKILicense Manager|Tk Dongle E]
Language

Erable stopping when users are connected.

Francais
Deutzch

taliano AUTO Dongle port
Espafiol
Dansk
Swenska
Magyar
hlederlands
Morsk:
Suomi
Portugués

o minutes of tolerance in case of network: disconnection (e 480 min)
Mote: The user token will be locked during that period.

o seconds of waiting for start the service. (max 7200 5)

QK Cancel

Figure 5: Settings window
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To change the settings

If SLicense.exe was not installed in the [DONGLE] folder, you
must specify the access path to the license file.

Enter the new access path to the license file, or click
the Browse button.

If you want to allow the service to be stopped while
users are still logged on, select the Enable stopping
while users are connected option.

If you want to change the display language of the
License Service Controller, select the desired
language from the Language list.

If you want to activate a tolerance period, enter the
value in minutes (max. 480 minutes). During this
period, you can continue to use the labeling software
even if access to the license server is interrupted.
The user token will be locked during the tolerance
period. The token can be released immediately when
the labeling software is closed by selecting the option
Release the network license when the application
is closed in the Network Administration dialog box
(Command Tools> Network Administration from the
labeling software).

The labeling software needs to be connected to the
license server for at least 6 minutes in order for the
tolerance period to become active.

+ Click OK to update the changes.

Changing the behavior of the service

By default, the service is started automatically when the
workstation is turned on. However, you can change the
behavior of the service in the Services window in the
Windows Control Panel. For more information, refer to the
documentation supplied by Microsoft.
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Maximum
number of users

Changing the service startup type
1 Select SLicense from the list of services.
2 Click Startup.

3 Enable the desired startup type. SLicense is configured to
start automatically by default.

Selecting a user account
1 Select the user account in the Log on as field.

2 Type and confirm the password and click OK in
the Service window.

In case you installed the License Service on a Windows®
workstation your network version is limited to a maximum
number of users. This means that a 10-user license allows
you to start 10 sessions of the labeling software
simultaneously. If an eleventh user tries to log on, an error
message is displayed indicating that the maximum number
of users has been reached. He or she must wait until one of
the connected users logs off.

To increase the simultaneous connections, you have to
install the License Service on a Windows® Server.

Troubleshooting

Two types of error messages can be displayed. The table
below lists possible problems and describes the
troubleshooting procedure.
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Protection key
not found

License Service
cannot create
the license file

- The key is not connected.

- The dongle is connected to the wrong
port (serial port, for example).

- A printer is connected to the dongle
and is switched off.

- The product has not been activated.

The license file could not be created in
the [TKDongle] folder. This may mean
that a user on the station on which
License Service was started does not
have the access rights required to write
to this folder. The network administrator
must assign the required access rights
(read, write, delete, and modify, if
applicable).

Managing shared resources

Shared
document files

A document can only be opened by one user in read/write
mode. If the same document is opened by other users, it is
opened in read-only mode. This means that only the first
user can modify and save the document.

The document can be printed from read-only
Q mode.

To provide security for the work of the group, the opening
mode for documents can be defined in the Tools >
Configuration > Document tab, by selecting the Open
documents as «read only» mode by default option.
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Shared data

Shared printing
logdfile

Shared file
timeout period

The Network Settings Wizard is used to configure data
sharing for variables, lists of values, and the printing logdfile.

To share data, you must specify a path and folder on the
network in step 3 of the wizard.

If you selected the generic settings mode in the

Network Settings Wizard, the printing logfile (which is very
useful for tracking all print jobs) can be configured in the
printing logfile window.

To share the printing logfile with all workstations, you must
first generate the log file on one of the workstations.

To generate a printing logfile
1 Go to Tools > Lodfile.

2 Enter the access path to the folder in which shared data
is saved and a file name for the printing logfile, then
select a text editor.

3 Enable your options on the Options tab. For more
information on the printing lodfile, refer to the online Help
system.

As with shared variables, if multiple users are
working on the same file, only one printing lodfile is
created and it tracks all print jobs for each user.
However, a user can generate a personal file.

When a shared file, such as a file of shared variables, is
opened by a user, it cannot be accessed by other users.
Others users must wait until it becomes available before
editing it. After a timeout period (defined by you), a message
is displayed asking the user if he or she wants to continue
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waiting or cancel the request.
To define the timeout period:

1 Go to Tools > Configuration.
2 Click the Others tab.

3 Type a value in the Shared files access timeout (ms) field.

Printing A flashing colored indicator indicates the status of the
current print job in the Print Status windows. This status is
only displayed if you display the Print window in the labeling
software.

* Green: The data is being printed.

» Orange: A user is currently using a shared resource
(printer or variable).

* Red: Error.

To display the print dialog box:
1 Go to Tools > Configuration and click the Printing tab.

2 Disable the Hide Cancel Print dialog box option.
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Notes for the network administrator

This section describes folders on the server and
workstations, and the required access rights.

Folders on the server

During installation, the [TKDONGLE] folder is created. It is
important for each user to have read/write access to the
shared TKDONGLE folder.

Users must be given, at minimum, read/write access
to all available folders in the default folders list
(Tools > Configuration> Default folders).
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